composer安装及加速

安装 Composer

Composer 需要 PHP 5.3.2+ 才能运行。

sudo curl -sS https://getcomposer.org/installer | php -- --install-dir=/home
sudo ln -s /home/composer.phar /usr/local/bin/composer

其他安装方法:https://pkg.phpcomposer.com/#how-to-install-composer

Packagist / Composer中国全量镜像镜像用法

有两种方式启用本镜像服务:

  • 系统全局配置: 即将配置信息添加到 Composer 的全局配置文件 config.json 中。见“方法一”。
  • 单个项目配置: 将配置信息添加到某个项目的 composer.json 文件中。见“方法二”。

方法一: 修改 composer 的全局配置文件(推荐方式)

打开命令行窗口(windows用户)或控制台(Linux、Mac 用户)并执行如下命令:

composer config -g repo.packagist composer https://packagist.laravel-china.org

方法二: 修改当前项目的 composer.json 配置文件:

打开命令行窗口(windows用户)或控制台(Linux、Mac 用户),进入你的项目的根目录(也就是 composer.json 文件所在目录),执行如下命令:

composer config repo.packagist composer https://packagist.laravel-china.org

就是去掉方法一的 -g 参数。

OK,一切搞定!试一下 composer install 来体验飞一般的速度吧!如果进度不明显,尝试添加 -vvv

取消镜像

composer config -g --unset repos.packagist

刷新 composer.lock 文件

composer update nothing
或者
composer update --lock

清空本地缓存

rm -rf vendor
composer clear-cache

发表评论

电子邮件地址不会被公开。 必填项已用*标注

1 + 18 =