composer安装及加速

安装 Composer

Composer 需要 PHP 5.3.2+ 才能运行。

其他安装方法:https://pkg.phpcomposer.com/#how-to-install-composer

Packagist / Composer中国全量镜像镜像用法

有两种方式启用本镜像服务:

  • 系统全局配置: 即将配置信息添加到 Composer 的全局配置文件 config.json 中。见“方法一”。
  • 单个项目配置: 将配置信息添加到某个项目的 composer.json 文件中。见“方法二”。

方法一: 修改 composer 的全局配置文件(推荐方式)

打开命令行窗口(windows用户)或控制台(Linux、Mac 用户)并执行如下命令:

方法二: 修改当前项目的 composer.json 配置文件:

打开命令行窗口(windows用户)或控制台(Linux、Mac 用户),进入你的项目的根目录(也就是 composer.json 文件所在目录),执行如下命令:

上述命令将会在当前项目中的 composer.json 文件的末尾自动添加镜像的配置信息(你也可以自己手工添加):

以 laravel 项目的 composer.json 配置文件为例,执行上述命令后如下所示(注意最后几行):

OK,一切搞定!试一下 composer install 来体验飞一般的速度吧!

发表评论

电子邮件地址不会被公开。 必填项已用*标注